29 ottobre 2008

Gentoo: attenzione a "sys-libs/com_err" e (forse) "sys-libs/ss"!

Se in questi giorni, facendo "emerge -uavDN world", portage vi dice che com_err sta bloccando l'upgrade di e2fsprogs, ovviamente controllerete le dipendenze legate a com_err PRIMA di rimuoverlo, vero? :)

Occhio che comunque "equery d com_err" delle volte non dice SEMPRE la verità.

Se, come me, avete fatto il pasticcio, usate "revdep-rebuild -i -l libcom_err.so.2" e, se necessari, pure "revdep-rebuild -i -l libss.so" per rimediare al pastrocchio %p...

Se wget vi blocca il riemerge xke vuole PURE LUI il libcom_err.so, ricompliatelo. Anteponete (se necessario) USE="-ssl" al comando.

/* dà capocciate alla scrivania */

4 commenti:

  1. Anche tu con gentoo unstable, eh? ;)

    RispondiElimina
  2. Non proprio. Diciamo che COMPLESSIVAMENTE, almeno a livello di system, è prevalentemente "stable", con qualche spruzzata di "~amd64" qui e là a livello di x11, gnome e stronzatille annesse e connesse. :)

    Ma queste cose mi sono successe pure su una gentoo hardened (stable, ça va sans dire!!!), anche se con un impatto relativamente più lieve :D

    RispondiElimina
  3. Gentoo e' per chi non vuole annoiarsi mai!

    Qualche tempo fa, ad esempio, mi aveva dato problemi dopo aver aggiornato le coreutils. Ogni comando che toccava i file come ad esempio mv, cp e compagnia bella restituiva un bell'errore/orrore. Piu' di una volta sono rimasto addirittura senza gcc funzionante ed ho dovuto scaricarne una versione binaria d'emergenza O_O

    Io pero' sono un amante del rischio e quindi non m'importa nulla di tutto cio' di cui sopra ;)

    RispondiElimina
  4. Io sono passato a stable poco tempo fa... troppo stress la unstable

    RispondiElimina

NOTA BENE: Se vi ostinate a commentare posts di un mese fa, scatta la moderazione (se non sono in vacanza, controllo quasi ogni giorno)... Ovviamente, se siete spammers vi cancello :)