19 ottobre 2008

Gentoo amd64, Firefox e Flash a 32bit...

Premessa: ho un sistema a 64bit con emulazione del 32bit (mi serve x wine).

Adobe probabilmente non farà MAI la versione a 64bit del plugin x linux (relativo blog)

Quindi l'unica soluzione ottimale che ho trovato finora per vedere le pagine web senza che mi si crashi il browser ogni 2x3 è stata quella di installare la versione a 32bit di Firefox (emerge mozilla-firefox-bin) e di usare direttamente il plugin Flash della Adobe (emerge netscape-flash), dato che il NSPluginwrapper non era propriamente stabile...

L'unica magagna ricorrente è che OGNI santissima volta che l'Adobe rilascia una nuova versione del plugin e gentoo la rilascia nel portage, l'emerge si comporta come se non glie ne freghi nulla del firefox a 32bit e mi cancella i link simbolici tra /opt/netscape/plugins/ (dove viene installato di default il plugin) e /opt/firefox/plugins/ (la cartella dei plugins del firefox a 32bit).

Dopo enne volte che ricreavo a mano i link simbolici mi sono stufata. Ora copio brutalmente da /opt/netscape/plugins/ il libflashplayer.so in /opt/firefox/plugins/ (da fare come root e a browser chiuso :))

(Il problema è ricordarmi di farlo, in primo luogo...)

4 commenti:

  1. Ciao Barbara

    .... uno scriptino no? :)

    Buona settimana

    RispondiElimina
  2. @gabriele: Nah, mi dimenticherei di lanciarlo :D

    RispondiElimina
  3. Potresti lanciarlo ogni volta che avvii firefox, invece di lanciare l'eseguibile lanci lo script, che alla fine lancia firefox... a me ci mette talmente poco a copiare i file dei plugin che ho fatto così.

    ps: io non ho 64bit ma tengo sincronizzata la directory plugins tra il firefox installato via rpm da quello installato a manina in /opt :)

    RispondiElimina
  4. @palin: potrei provare. Devo solo trovare il tempo di litigare pure col bash :)

    RispondiElimina

NOTA BENE: Se vi ostinate a commentare posts di un mese fa, scatta la moderazione (se non sono in vacanza, controllo quasi ogni giorno)... Ovviamente, se siete spammers vi cancello :)